Members | Sign In
ScannerDanner Forum > Post your repair questions here
avatar

1998 ford windstar nightmare

posted Mar 22, 2016 11:42:39 by bdazsvt03
To start this off. The van shut off driving down the road. No symptoms at all. Once it stopped. I got out and heard clicking coming from under the hood. Popped the hood checked it out and it was the fuel pump relay and the IAC motor. The service engine light is dimming constantly and there is no communication with DLC. DLC checked out with power and grounds just for good measure. So i went after the PCM grounds and all seemed ok. SCOPE DOES SHOW SOME SPIKING so i removed all grounds i could find and cleaned then with no change. I do not have fuel pressure. I have spark, i have injector pulse, i have 5 volt reference at dpfe and tps. I am having trouble finding an accurate wiring diagram. I use alldatapro. And found a mitchell but they all say it has a CCRM. 1998 does not.there is a wire that monitors the fuel pump from pcm i have eliminated the fuel pum because it has been unplugged at the harness and relay still clicks. The green and yellow wire going to the inertia switch is dim and pulsing as is the white and blue signal wire from iac. I dont want to call a PCM i am not a parts changer i am a diagnoser! Any ideas would be helpful. I have some other info i can provide as to what i have done. This is getting to l9ng. Thanks
page   first prev 1 2
17 replies
avatar
Noah said May 24, 2016 14:33:29
Awesome, I was wondering what happened with this one.
Massachusetts, USA
avatar
Johnathon Balderas said May 25, 2016 20:30:22
Wow pretty cool. Seemed like a pcm issue.
Login below to reply: