Members | Sign In
ScannerDanner Forum > Post your repair questions here
avatar

Suzuki grand vitara.2005

posted Jun 23, 2016 21:39:53 by CyrusKiur
The car doesnt start.no spark no injector pulse.the error code is p1621 and have programmed the immobilizer system.koeo commanded ignation to spark using test light and sparked that tells me all ignation coils are fine and also pcm but on injectors side nothing at all.wen i use my test light connected to battery negative to make injectors open,nothing happens.now my question is even if i my have immobilizer problem could this make injectors not to fire wen i do bypass test?kindly help!
page   1
8 replies
avatar
Tyler said Jun 25, 2016 19:48:20
Hey Cyrus!

Just so I understand you correctly, you're doing a bypass test on the crank sensor to get the coils to fire, right? Nicely done, if that's the case.

As for the injectors, I have to ask, are you sure you're getting power? You using a test light connected to battery negative *should* make an injector click, provided there's a good power feed and that the test light carries enough current to energize the injector.

I'm not sure the cam/crank setup on this Suzuki, but I do know that some systems will require both cam and crank inputs to fire coils and injectors. This system may be able to create spark with just the crank input.

P1621 is still there after reprogramming the immobilizer?
avatar
CyrusKiur said Jun 25, 2016 20:57:09
P1621 is still there,have asked my friend who deals with car immobolizer system to check whether key,coil antenna and ecu are communicating with each other and everything looks fine.injectors have 12 volts always but i think the problem is my test light.I hope if u have Suzuki grand vitara 2005 immobilizer wiring diagram kindly help me with it here.
avatar
CyrusKiur said Jun 25, 2016 20:58:23
P1621 immobilizer communication line error.
avatar
juergen scholl said Jun 26, 2016 04:39:16
look here for the diagram:

http://bbbind.com/tech_database.html
[Last edited Jun 26, 2016 04:40:52]
avatar
CyrusKiur said Jun 26, 2016 09:16:48
Thank u for wiring diagram help but can't see immobilize system
avatar
cheryl hartkorn said Jun 26, 2016 14:45:23
maybe try a capacitor discharge. unhook both battery cables and use a jumper wire to connect them together for a few minutes. NOT the battery TERMINALS themselves. and see if that code comes back when attempting to start it when the battery is hooked up
avatar
cheryl hartkorn said Jun 26, 2016 14:53:36
also I will check and look on alldata and see what sets the code see if a wiring diagram is available
avatar
CyrusKiur said Jun 27, 2016 17:07:38
Ok thank u guys.
Login below to reply: